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circuit as specified in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of
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Disclaimer: CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS
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FOR A PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials
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malfunction or failure may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product
in a life-support systems application implies that the manufacturer assumes all risk of such use, and in doing so indemnifies
Cypress against all charges. 

Use may be limited by and subject to the applicable Cypress software license agreement. 

PSoC Designer™ and Programmable System-on-Chip™ are trademarks and PSoC® is a registered trademark of Cypress
Semiconductor Corp. All other trademarks or registered trademarks referenced herein are property of the respective
corporations.

Flash Code Protection

Cypress products meet the specifications contained in their particular Cypress PSoC Data Sheets. Cypress believes that its
family of PSoC products is one of the most secure families of its kind on the market today, regardless of how they are used.
There may be methods, unknown to Cypress, that can breach the code protection features. Any of these methods, to our
knowledge, would be dishonest and possibly illegal. Neither Cypress nor any other semiconductor manufacturer can
guarantee the security of their code. Code protection does not mean that we are guaranteeing the product as "unbreakable."

Cypress is willing to work with the customer who is concerned about the integrity of their code. Code protection is constantly
evolving. We at Cypress are committed to continuously improving the code protection features of our products.
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1. Introduction

Thank you for your interest in the CY3240-I2USB Kit. The CY3240-I2USB can be used with the
Bridge Control Panel that is installed with PSoC Programmer. The kit is designed to test, tune, and
debug programs that have an I2C slave interface. This document describes the working of CY3240
and includes example projects, which will help you get started with the bridging tool. You can also
develop custom programs using PERL, Python, C++, and C# languages. These custom applications
allow generating complex testing, debugging, and validation systems using PSoC Programmer
COM.

You can evaluate the kit using the example projects provided with the kit. The example projects help
to: 
■ Explore I2C-USB communication between the PC and slave interfaced via I2C slave interface 

connector of the bridge
■ Customize the designs provided along with the kit

The CY3240 I2C-USB Bridge board is configured with the I2C-USB Bridge Board example project
when shipped. See Chapter 5 for more details.

Chapter 2 of this document describes the installation and configuration of CY3240-I2USB. Chapter 3
explains the programming of a PSoC 1 device with PSoC Programmer and how to use the kit with
the help of an example project. Chapter 4 describes the hardware operation. Chapter 5 provides
instructions to create a simple example project. The Appendix section provides the schematics and
BOM for the CY3240-I2USB kit. 

Evaluate the sample projects provided with the kit and then experiment with the kit hardware and
software to create your own designs.

1.1 Kit Contents
The CY3240-I2USB Bridge Kit contains:
■ I2C-USB Bridge
■ I2C demo target board
■ USB A to Mini B cable
■ CY3240-I2USB kit CD

Inspect the contents of the kit. If any parts are missing, contact your nearest Cypress sales office for
further assistance.

1.2 Bridge Control Panel Software
Bridge Control Panel is installed along with PSoC Programmer and enables the bridge to communi-
cate with the PC. It is used to send and receive data from the device connected to the bridge. 
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1.3 Additional Learning Resources
Visit www.cypress.com for additional learning resources in the form of data sheets, technical
reference manual, and application notes.

■ Application Note - Using Cypress I2C Port Expander with Flash Storage:
http://www.cypress.com/?rID=2694 

■ PSoC CY8C24894 - Features and Chip functionality:
http://www.cypress.com/?rID=37765

■ PSoC CY8C21123 - Features and Chip functionality:
http://www.cypress.com/?rID=3335

■ For more information regarding PSoC Designer functionality and releases:
www.cypress.com/go/psocdesigner

■ For more information regarding PSoC Programmer, supported hardware and COM layer:
www.cypress.com/go/psocprogrammer

■ For a list of PSoC Designer-related trainings:
http://www.cypress.com/?rID=40543

1.4 Document History

1.5 Documentation Conventions 

Revision PDF Creation 
Date

Origin of 
Change Description of Change

** 01/25/2011 RKPM Initial version of kit guide

Table 1-1.  Document Conventions for Guides

Convention Usage

Courier New
Displays file locations, user entered text, and source code:
C:\ ...cd\icc\

Italics Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold] Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths:
File > Open > New Project

Bold Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation:
2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.
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2. Getting Started

This chapter describes the installation and configuration of CY3240-I2USB. 

2.1 CD Installation
To install the kit software, follow these steps:
1. Insert the kit CD into the CD drive of your PC. The CD is designed to auto-run and the kit installer 

startup screen appears.
Note You can also download the latest kit installer from http://www.cypress.com/go/CY3240-
I2USB. Download the ISO file and create an installer CD or extract the ISO using WinRar and 
install the executables.

2. Click Install CY3240-I2USB Bridge Kit to start the installation, as shown in Figure 2-1.

Figure 2-1.  CY3240-I2USB Menu

Note If auto-run does not execute, double-click cyautorun.exe file on the root directory of the 
CD, as shown in Figure 2-2.
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Figure 2-2.  Root Directory of CD

3. On the startup screen, click Next to start the installer.
4. In the InstallShield Wizard, choose the folder location to install the setup files. You can change 

the location of the folder for the setup files using Change, as shown in Figure 2-3.
5. Click Next to launch the installer.

Figure 2-3.  InstallShield Wizard

6. On the Product Installation Overview screen, select the installation type that best suits your 
requirement. The drop-down menu has three options: Typical, Complete, and Custom, as 
shown in Figure 2-4.

7. Click Next to start the installation.
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Figure 2-4.  Installation Type Options

8. When the installation begins, a list of packages appears on the Installation Page.
9. A green checkmark appears against every package that is downloaded and installed, as shown 

in Figure 2-5.
10.Wait until all the packages are downloaded and installed successfully.

Figure 2-5.  Installation Page
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11.Click Finish to complete the installation, as shown in Figure 2-6.

Figure 2-6.  Installation Complete Page

After the software installation, verify that you have all hardware and drivers set up for the I2C-USB kit
by connecting the bridge to your PC via its USB interface. Because this is the first time you have
connected this board to the PC, initial drivers are installed. Follow the instructions to complete the
installation process. Also, verify your installation by opening PSoC Programmer with the kit board
attached to USB. 

2.2 PSoC Designer
PSoC Designer 5.1 is the revolutionary integrated design environment (IDE) that helps to customize
PSoC to meet specific application requirements. PSoC Designer software accelerates system bring-
up and time-to-market.
■ To open PSoC Designer, click Start > Programs > Cypress > PSoC Designer 5.1 > 

PSoC Designer 5.1
■ To create a new project, click File > Create New Project
■ To open an existing project, click File > Open
■ To experiment with the example projects, go to Example Projects on page 31
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Figure 2-7.  PSoC Designer Interconnect View

Note For more details on PSoC Designer, see the PSoC Designer IDE Guide located at:
<InstalledDirectory>:\Cypress\PSoC Designer\<version>\Documentation.
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2.3 PSoC Programmer
To open PSoC Programmer, click Start > Programs > Cypress > PSoC Programmer 3.12 >
PSoC Programmer 3.12.

To successfully program the device, follow these steps:
1. Select the I2C-USB bridge in Port Selection, as shown in Figure 2-8.

Figure 2-8.  PSoC Programmer Window

2. Click the File Load button to load the hex file.
3. Click the Program button to program the hex file on the chip.
4. Close PSoC Programmer.

2.4 Bridge Control Panel
The Bridge Control Panel is used with CY3240 I2C-USB Bridge to enable communication with I2C
slave devices. This program is used to configure I2C devices and also to acquire and process data
received from I2C slave devices. The Bridge Control Panel helps in optimizing, debugging, and cali-
brating the target application.
1. Click Start > Programs > Cypress > Bridge Control Panel 1.2 > Bridge Control Panel
2. Select Power Supply, as highlighted in Figure 2-9.
3. Select the port connectivity.
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Figure 2-9.   Selecting the Bridge

Note For more information, go to Bridge Control Panel > Help > Help Contents.

2.5 Install Hardware
No hardware installation is required for this kit.
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3. Kit Operation

3.1 Introduction
The device meets the requirements of I2C Specification for standard and fast speed I2C devices,
and supports USB HID devices. The bridge is powered by the USB and consumes less than
500 mA. The device can be configured for several I2C clock rates such as 50 kHz, 100 kHz, and
400 kHz.

The number of devices that can be connected is constrained only by the I2C address limit and phys-
ical ability of the I2C bus. For more details, see the I2C Specifications.

The USB communication function uses two 64-byte packets: one for input data flow and the other for
output data flow. The maximum bandwidth of this configuration is 64 bytes. This is sufficient for most
I2C-USB bridge applications (Figure 3-1).

Figure 3-1.  I2C-USB Bridge
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3.2 Connect Bridge to Device 
Figure 3-2.  Bridge to Device Connection

Perform the following steps to connect the device to I2C-USB bridge, as shown in Figure 3-2:
1. Connect GND of the device to GND of the bridge.
2. Connect the SDA and SCL lines to the bridge. 

Bridge has 2.2 k pull-up resistors connected to +5 V. The INT pin is a pull-down bidirectional pin 
that can be used as an additional signal between the bridge and I2C slave device for functions 
such as sleep mode control. 

3. Power the device from the Vdd pin on the bridge, if it does not have its own power supply. Note 
that the Vdd connection between the bridge and target board is required, even if the board is self-
powered. Optionally, the bridge can provide 3.3 V or 5 V, or work with an externally powered 
board using 2.4 V to 5.6 V.

4. When the connection between the bridge and USB is successful, the LED (green) lights up, as 
shown in Figure 3-3. 

Figure 3-3.  Connecting Bridge to USB.

5. Open the Bridge Control Panel from the PC to work with the bridge.

3.2.1 Program I2C-USB Bridge 
The CY3240 I2C-USB Bridge can be programmed using a MiniProg at the programming header of
the bridge. To use MiniProg, use the ISSP Programming Header (J2) on the board as highlighted in
Figure 3-4.
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Figure 3-4.  ISSP Programming Header

3.3 Connect Demonstration Board to Bridge
1. Connect I2C slave demonstration board to bridge, as shown in Figure 3-5.

Figure 3-5.  Demonstration Board and Bridge Connection

2. Select +5V as power supply to the board from Bridge Control Panel. The LED (red) on the bridge 
board lights up, as shown.

Figure 3-6.  LED (Red) on the Bridge Board

3. Click List; the bridge will find I2C slave demonstration board at 0x00 address.

3.3.1 Run Demonstration Board Test
The demonstration board has built-in temperature sensor and photodiode. The measurement results
of these are sent over I2C.
1. Open the Variable Setting dialog box from the Chart menu.
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Figure 3-7.  Variable Setting Box

2. Load the demo.ini file by clicking the Load button, as shown in Figure 3-7. The demo.ini file ini-
tializes light and temperature variables and is available in the CY3240-I2USB kit CD or at the fol-
lowing location: <Installed_directory>:\Cypress\CY3240-I2USB.

3. Load demo.iic file for iic commands that can be sent to demo target board; the demo.iic file is 
available in the CY3240-I2USB kit CD or at the following location: 
<Installed_directory>:\Cypress\CY3240-I2USB

Go to File > Open File > demo.iic to select the file.
4. The first two lines in the demo.iic file show how to control the LEDs on the board. Position the 

cursor in the first line and press [Enter] to send the command. Repeat for the second command 
line. Observe that, on sending the first command, the LED1 turns off. The second command 
reduces the LED intensity by 50 percent.
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Figure 3-8.  Bridge Control Panel Editor Screen View

5. Click in the last line, which reads temperature and light data from the device and then click the 
Repeat button. On clicking Repeat, the command that is sent last is repeated until Stop is 
clicked. This makes data collection easier. The data received from slave can be viewed either 
graphically or in a tabular form.

6. Click the Chart tab to view data graphically, as shown in Figure 3-9.
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Figure 3-9.  Bridge Control Panel Graphical Screen View 

7. Click the Stop button to stop scanning.
8. Click the Table tab to view data in a tabular form, as shown in Figure 3-10.
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Figure 3-10.  Bridge Control Panel Tabular Screen View

The File menu has these options:
■ Save Send Data - To save the data sent to the demo target board from Bridge Control Panel. 
■ Save Receive Data - To save received data shown on the status window of Bridge Control Panel.

Go to Bridge Control Panel Help from the Help menu for more information on the Bridge Control
Panel and iic command format.
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4. Hardware

4.1 System Block Diagram
The CY3240-I2USB kit has two boards:
■ I2C-USB Bridge board
■ Demo target board

I2C-USB Bridge board consists of:
■ PSoC CY8C24894 chip
■ USB Mini B connector
■ ISSP programming header.
■ GPIO pins
■ I2C slave interface connector

Figure 4-1.  I2C-USB Bridge Board

Demo target board consists of:
■  CY8C21123 chip
■  LED
■  Photodiode
■  ISSP programming header/data connector

PSoC
CY8C24894

ISSP
Programming

Header

I2C Slave
Connector

GPIO Pins

USB Mini B Connector
(Communication and

Power Supply of
3.3V/5V)
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Figure 4-2.  Demo Target Board

4.2 Functional Description
The I2C-USB Bridge is connected to the PC in the same way as an HID device. It requires no
additional driver when connected to a PC installed with Windows. This I2C-USB Bridge works as a
master in the I2C bus and is controlled by the PC program via USB. In addition, a demonstration PC
program is included with the project to demonstrate bridge operation with connected I2C slave. 

Figure 4-3.  I2C-USB Bridge with Demo Target Board

PSoC
CY8C21123

ISSP
Programming
Header/Data

connector

Photo-diode LED

Photo Diode Output LEDs
Internal Power Jumper

PSoC CY8C24894 Chip

GPIO Pins

ISSP Programming Header

PSoC CY8C21123 Chip
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4.2.1 PSoC CY8C24849 Chipset
The PSoC CY8C24894 on CY3240-I2USB Bridge board is pre-programmed to function as full fea-
tured, full speed (12 Mbps) USB. This device enables creating customized peripheral (I/O) configu-
rations that match the requirements of each individual application.

The PSoC device also performs the following functions:
■ Lights up LED (green) on connecting the bridge to host via USB.
■ Lights up LED (red) on external power supply to target device.
■ Acts as interface between the host and target device.

Figure 4-4.  PSoC CY8C24894 Hardware Schematic

4.2.2 USB Mini B Connector
USB Mini B connector communicates between the PC and bridge. It is used to power up the bridge
and supply voltage range of 3.3 V or 5 V to target board. These plugs are always oriented down-
stream towards the USB device. It has SN65220, a single transient voltage suppressor, to provide
electrical noise transient protection to USB port.
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Figure 4-5.  USB Mini Port Schematic

4.2.3 ISSP Programming Header
The in-system serial programming header is used to:
■ burn the hex code onto the chip
■ connect the MiniProg for programming the chip

The ISSP connector consists of the following:

Table 4-1.  ISSP Programming Header Connection Details

Pin No Connection Description
1 +V Device To supply voltage to the bridge

2 GND Ground pin of the bridge

3 INT Interrupt pin

4 SDA Serial data line

5 SCL Serial clock line
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Figure 4-6.  ISSP Programming Header Schematic

4.2.4 GPIO Pins
GPIO plays an important role in customizing the applications.

Table 4-2.  GPIO Pin Connectivity table

Terminal Connection Port PIN No. Description
TP12 P2[4] 43 External Analog Ground (AGND) input

TP11 P2[6] 44 External Voltage Reference (VREF) input

TP10 P0[0] 45 Analog column mux input

TP9 P0[2] 46 Analog column mux input

TP8 P0[4] 47 Analog column mux input

TP7 P0[6] 48 Analog column mux input

TP6 P0[7] 51 Analog column mux input

TP5 P0[5] 52 Analog column mux input and column output

TP4 P0[3] 53 Analog column mux input and column output

TP3 P0[1] 54 Analog column mux input

TP2 P2[7] 55 GPIO

TP1 P2[5] 56 GPIO

TP13 P2[2] 42 GPIO
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Figure 4-7.  GPIO Pin Schematic

4.2.5 I2C Slave Interface Connector
The I2C slave interface connector is used to communicate data between the target device and
bridge board. It consists of two devices, MAX3378 and SN721.

MAX3378
■ Is used to convert the voltage level between the target device (Vcc) and host level voltage (VL)

■ Has bidirectional level translation, accepts VL +1.2 V (Min) to +5.5 V (Max); Vout(High) is 0.6 
times VL (if source current is 0.02 mA) and Vout(Low) is 0.4 V

SN721
■ An array of SCR/diode bipolar structure for ESD and over-voltage protection
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Figure 4-8.  I2C Slave Interface Schematic

4.2.6 Demo Target Board
The target board is used to light up the two LEDs on receiving data from host and transfer the data,
acquired from photo diode to host.

PSoC device (CY8C21123) is used to control the two LEDs based on input from the host using
Bridge Control Panel. The PSoC device updates the I2C register with the sensor information, which
can be read by any I2C master.

Table 4-3.  CY8C21123 Pin Connectivity

Pin No. Port No Description
6 P0[4] LED1

7 P0[2] LED2

1 P0[5] Photo-diode

8 P1[0] Voltage supply

3 P1[1] Ground

2 P0[3] Interrupt

5 Vcc Serial clock

4 GND Serial data

[+] Feedback 

http://ccc01.opinionlab.com/o.asp?id=wRiLHxlo&prev=docurate_001-66660_pdf_p_29


30 CY3240-I2USB I2C-USB Bridge Guide, Doc. # 001-66660 Rev.**

Hardware

Figure 4-9.  Demo Board Chip Schematic
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5. Example Projects

All example projects are available in the CY3240-I2USB kit CD or at the following location:
<Installed_directory>:\Cypress\CY3240-I2USB\Firmware

5.1 Example Project 1: I2C-USB Demo Target Board Project

5.1.1 Project Description
This example project demonstrates the data transfer between target board and host. The target
board has a photodiode to measure light intensity and temperature values, which are acquired by
the PSOC device (CY8C21123) to transmit to host.

This project uses the following modules to display temperature and light intensity values:

ADC10: Used to obtain the digital values for light intensity and temperature. Input to the ADC mod-
ule is switched between light input and temperature input once every 551 scan cycles.

EzI2C: Configures the PSoC on target board as I2C slave and is used to transfer data to the bridge
board where the PSoC configured as I2C master.

PWM8: Used to handle the LED command from the host and vary the LED intensity accordingly.
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5.1.2 Hardware Connections 
Figure 5-1.  Functional Blocks
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Example Projects

5.1.3 I2C-USB Demo Target Board Flowchart
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5.1.4 Verify Output
Load demo.iic file from the Bridge Control Panel, as explained in Run Demonstration Board Test on
page 17. The light intensity and temperature transmitted by target board to host is shown on the
Bridge Control Panel screen, as shown in Figure 5-2. 

Figure 5-2.  Light Intensity and Temperature Values on Bridge Control Panel 

5.2 Example Project 2: I2C-USB Bridge Board Project

5.2.1 Project Description
This project demonstrates communication between the bridge and host. After each packet is
received by the bridge, an acknowledgement is sent to the host before the next transfer operation
begins.

This project uses the following modules:

CMPRG: Used to compare the data programmable reference threshold.

PWRFB: Used to set the power level for this application.

TIMER8: Used to wake up the application from sleep mode. 
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5.2.2 Hardware Connections 
Figure 5-3.  Functional Bocks
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Example Projects

5.2.3 I2C-USB Bridge Flowchart
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5.2.4 Verify Output
When connected to the demonstration board, LED (green) blinks on the bridge indicating transfer
operation between the bridge and PC.

Figure 5-4.  Verify Output
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A. Appendix

A.1 Schematic

A.1.1 I2C-USB Bridge Schematic
Figure A-1.  Reverse Current Protection Schematic
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Figure A-2.  USB Connection with Voltage Suppressor Schematic

Figure A-3.  Diode Schematic
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Figure A-4.  Voltage Regulator Schematic
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Figure A-5.  PSoC CY8C24894 Schematic

A.1.2 Demo Target Board Schematic
Figure A-6.  Demo Board Schematic
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A.2 I2C-USB Bridge Board Layout
Figure A-7.  Top View

Figure A-8.  Bottom View

A.2.1 Demo Target Board Layout
Figure A-9.  Top View
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A.3 BOM

A.3.1 I2C-USB Bridge BOM Rev. E

Item Qty Reference Description Manufacturer Mfr Part Number

PCB Cypress Semiconductor PDC-9334
1 1 C1 CAP CER .10UF 25V X7R 10% 0805 TDK C2012X7R1E104K

2 1 C2 CAP CER 1.0UF 10V 10% X7R 0805 Murata Electronics North 
America GRM21BR71A105KA01L

3 1 C3 CAP CER 2.2UF 16V Y5V 1206 Murata GRM31MF51C225ZA01L
4 1 C4 CAP CER 10000PF 50V 10% X7R 1206 Murata GRM319R71H103KA01D
5 2 C5, C6 CAP CERAMIC .01UF 100V X7R 0603 Kemet C0603C103K1RACTU
6 1 R1 RES 52.3K OHM 1/10W 1% 0603 SMD Yageo RC0603FR-0752K3L
7 1 R2 RES 5.1K OHM 1/10W 5% 0603 SMD Yageo RC0603JR-075K1L
8 1 R3 RES 24.0K OHM 1/10W 1% 0603 SMD Yageo RC0603FR-0724KL
9 1 R4 RES 6.8K OHM 1/10W 5% 0603 SMD Yageo RC0603JR-076K8L
10 1 R5 RES 51K OHM 1/8W 5% 0805 SMD Yageo RC0805JR-0751KL
11 1 R6 RES 10K OHM 1/10W 5% 0603 SMD Yageo RC0603JR-0710KL
12 1 R7 RES 30.1K OHM 1/10W 1% 0603 SMD Yageo RC0603FR-0730K1L
13 1 R8 RES 51K OHM 1/10W 5% 0603 SMD Yageo RC0603JR-0751KL
14 2 R9, R10 RES 22 OHM 1/8W 5% 0805 SMD Panasonic - ECG ERJ-6GEYJ220V
15 2 R11, R12 RES 300 OHM 1/10W 5% 0603 SMD Yageo RC0603JR-07300RL
16 1 R13 RES 100K OHM 1/10W 5% 0603 SMD Rohm MCR03EZPJ104
17 2 R14, R15 RES 7.5K OHM 1/10W 5% 0603 SMD Yageo RC0603JR-077K5L
18 2 R16, R17 RES 30K OHM 1/10W 5% 0603 SMD Yageo RC0603JR-0730KL

19 3 R18, R19, 
R20 RES 47 OHM 1/10W 5% 0603 SMD Yageo RC0603JR-0747RL

20 1 J1 CONN HEADER VERT 2POS .100 TIN Molex/Waldom Electronics 
Corp 22-28-4020

21 1 J2 CONN HEADER VERT 5POS .100 TIN Molex/Waldom Electronics 
Corp 22-28-4050

22 1 J3 CONN HEADER .100 SNGL STR 5POS 3M Electronics 929850-01-05-10

23 1 J4 CONN USB RCPT MINI-B 5POS RT ANG Delphi Connection Sys-
tems 15430262-110

24 2 F1, F2 POLYSWITCH 1.10A RESET FUSE SMD Tyco Electronics/Ray-
chem Circuit Protection MINISMDC110-2

25 1 D1 * LED 660NM RED WTR CLR 1206 SMD Lumex Opto/Components 
Inc SML-LX1206SRC-TR

26 1 D2 * LED 565NM WTR CLR GREEN 1206 SMD Lumex Opto/Components 
Inc SML-LX1206GC-TR

27 2 D3, D4 Supressor 5V SMB package Littelfuse Inc SMBJ5.0CA
28 1 U1 IC LDO REG 1A SOT223-6 TPS73701 Texas Instruments TPS73701DCQ
29 1 U2 CY8C24894 Cypress Semiconductor CY8C24894-24LFXI
30 1 U4 * IC Single USB Port TVS SOT-23-6 Texas Instruments SN65220DBVT
31 1 U5 IC LVL XLTR LV 8MBPS 14-TSSOP Maxim MAX3378EEUD+
32 1 U6 TVS Array ESD 6 Input 8-SOIC Littelfuse Inc SP721ABG
33 2 * 000 RES 0.0 OHM 1/8W 5% 0805 SMD Rohm MCR10EZHJ000
34 1 * 000 RES 0.0 OHM 1/8W 5% 0603 SMD Rohm MCR03EZPJ000

35 1 J1 * Shunt 3M 929950-00
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A.3.2 Demo-Target Board R

Item Qty Reference Description Manufacturer Mfr Part Number Digi-Key Part 
Number

PCB Cypress Semiconductor PDC-9355
1 1 C1 CAP 100nF 25V CERAMIC X7R 0805 Panasonic - ECG ECJ-2VB1E104K PCC1828CT-ND
2 1 R1 RES 75K OHM 1/8W 5% 0805 SMD Yageo America RC0805JR-0775KL 311-75KARCT-ND
3 2 R2, R3 RES 1.0K OHM 1/8W 5% 0805 SMD Yageo America RC0805JR-071KL 311-1.0KARCT-ND
4 1 D1 Visible Light Sensor Microsemi Inc LX1972IBC
5 2 D2, D3 LED RED CLEAR 0805 SMD LITE-ON INC LTST-C170CKT 160-1176-2-ND
6 1 U1 IC PSoC 21x23 8SOIC Cypress Semiconductor CY8C21123-24SXI
7 1 J1 CONN HEADER .100 SNGL STR 5POS Samtec TSW-105-07-T-S SAM1035-05-ND
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